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digiXMAS Directory Submitter 

INTRODUCTION 

DigiXMAS Directory Submitter is SEO friendly, semi-automated directory submission tool that 

quickly submits your websites to thousands of free directories. 

HOW IT WORKS? 

According to your site profile and semi-automated category selection, the tool sends submission 

request directly to directories and analyses response to report the result. You don’t have to visit 

the directories.  

KEY FEATURES 

- Smart, self-learning category selection algorithm guaranties that your website is submitted 

to most relevant category. 

- De-CAPTCHA service integrated. 

- Automated submit is supported for directories with known category structure. 

- Automated submit with smart category suggestion. 

- Automated email confirmation. 

- Fully automated submission by copy category selections for same niche’s websites. 

- Support smart category filtering by keywords. 

- Long list of free general directories with Google Page Rank, updated every day. 

- Automated check for site’s listing in directories with showing exact anchor text. 

- Possibility of manual image verification or category adjustment during submission. 

- Automated record of submission error messages. 

- Up to 50 concurrent connections that reduce your time to minimum. 

- Automatic rotation of unlimited number of anchor text and description text. 

- Support of “tokens” randomization for anchor text and description text. 

- Automatic record of anchor text, submission status, submission date, and selected category. 

- Support of online mode, so your directory list is always “fresh”. 

- Possibility of re-sending submission request if failed. 

- Colorful directory list that clearly shows the submission status of each site. 

- Flexible directory list sort feature (by PR, Url, submission status, submission date) 

- Detailed submission reports in RTF, CSV and HTML format. Customized HTML report is 

also supported. 

- Support of multiple sites in single account. 

- Support of connection via proxy. 

- Flexible service packages that fit your needs.  

STEP-BY-STEP GUIDE 

1. Register a Free Account 

You need an account to launch our tool. Go to register page 

http://www.digixmas.com/users/register.php to register a free account.  

2. Download  
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Go to Download Page in http://www.digixmas.com to download digiXMAS Directory 

Submitter. 

3. Install 

Double click to downloaded installer to install digiXMAS Directory Submitter. 

4. Start and Logon 

Select the tool from Start Menu or double click to shortcut on your desktop to launch the 

tool. Main window and logon dialog will be shown. Enter username and password to log 

on. Software automatically downloads directory list from server. 

 

Figure 4.1: DigiXMAS Directory Submitter Main Window 

5. Credits Manage 

For free, you can submit to 150 PR0 directories only. 

To submit your site to whole directory list, you need to buy a credit for your site. 

You can buy individual credit for each site, or purchase bigger package at once: Premium 

package with 20 credits, Featured package with 10 credits or Economic package with 5 

credits.  

Go to menu Credits -> Purchase Credits. A webpage for purchasing will appear. 
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You can check number of credits available on your account. Select menu Credits -> Check 

Credits. 

If necessary, you can assign a credit to active site. Select menu Credits -> Assign Credit. 

6. Add Your Site  

Go to menu My Site -> Add a Site, Add a site dialog will appear.  

 

Figure 6.1: Add a Site Dialog 

Credit assign option tells how to assign credit to new site: “Auto” means a credit will be 

assigned if any is available on your account, “Don’t” means you want to use free service 

for new site, even you have credits available. 

Enter your site information or import site’s profile from text file and click OK to 

continue. 

Simple “tokens” randomization is supported for title and description text. See bellow 

example for syntax of text with tokens: 

“I bought my {home|house|family house} by {mortgage|loan}.” 

Tokens-in-tokens randomization is also supported. See below for example: 

“Do you understand next sentence: {this is {my|our} {home|house} | These are {my|our} 

houses}? “ 

The tool will randomize the tokens while submitting to directories. 
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Note:  

• See the Appendix A for instructions how to create site’s data file for importing. 

• Don’t forget check your text with tokens by clicking Preview button. 

7. Submit 

a. Submit  Options 

Several arguments can be adjusted to make your submission most comfortable. 

Select Submit->Options from main menu, the Options dialog will appears: 

 

Figure 7.1: Submission Options Dialog 

b. Enable DECAPTCHA Service (Optional) 

The tool supports decaptcha service from guys at http://www.decaptcher.com. Also, 

many other services, like DeathByCaptcha, provide decapcther’s interface. So, our 

tool can work with them too. 

After registering an account, purchasing service credits from them, you can configure 

the tool by selecting Tools > Decaptcha Service: 
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Figure 7.2: Decaptcha Service Dialog 

Choose My Decaptcher Account options; enter your Decaptcher account’s username 

and password.  

Enable this service by checking the Enable option. 

If enabled, the tool will send CAPTCHA images to decaptcher.com and receives the 

text on it. You won’t need to enter! 

Note:  

• We are reseller of the decaptcha service from http://www.decaptcher.com. 

Visit http://www.digixmas.com/tos.php for terms of service and detailed 

service pricing. 

c. Auto Submit Options 

The tool learns while you are submitting and in many cases it knows exactly what 

category you will select. For those cases, the tool can submit automatically. 

The options for Auto Submit can be adjusted by choosing Submit > Auto Submit. 

 

Figure 7.3: Auto Submit Dialog 
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You can enable automatic submission feature by checking on Enable Auto Submit. 

If enabled, the tool will auto submit your sites to directories that:  

1) No CAPTCHA presents or De-CAPTCHA service enabled;  

2) The tool knows directory’s category structure and it’s sure about your selection for 

it.  

3) If Suggest the Best Matching Category is enabled, the tool auto selects the best-

matching category based on your previous selections. 

Note:  

• Enable this feature only in the case you are sure that all category selections 

you’ve made were correct! 

d. Select working site: 

Your sites are listed in dropdown combo box located at the left side on the main 

window. Select the site that being submitted from the list. The detailed information 

about active site is shown below the URL. 

e. Start submitting: 

You can start to submit by choosing from menu Submit, or clicking the submit 

buttons on toolbar. Four options are available:  

- Submit to pending directories: Select Submit->Submit to Pending. 

- Submit to bypass directories (from previous sessions): Select Submit->Submit 

to Bypassed. 

- Re-send submission requests that failed: Select Submit->Re-Send Failed 

Submissions. 

- Customized Submission: Select Submit->Customized Submit. A dialog will be 

shown to allow you to choose 1) PR and number of directories or 2) from/to 

directories index that your site will be submitted to. Also, you can filer 

directories by CAPTCHA attributes, or directory load speed. 

 

Figure 7.8: Customized Submission Dialog 
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You have to confirm category submission for each directory. The tool will offer most 

relevant category and give the chance to change before submit to directory. For first 

submissions you have to choose it by yourself, and then your selection is recorded 

and will be used for next category suggestion. 

 

Figure 7.9:  Category selection and image verification 

The suggested categories are order by priority. Use the << and >> button to move 

between them. 

The tool randomly selects Title, if you want to change, select it from dropdown list. 

Categories can be filtered by category keywords. You can turn on or turn off the category 

filter by clicking appropriated small buttons S or A on the dialog. 

If directory requires image verification, you can do it here. 

If you would like to stop submission process that running, click to Stop submission 

checkbox on this dialog. System will try to finish as soon as possible after completing of 

submission requests that already sent. 

Note: Category selection confirmation plays very important role in our self-learning 

algorithm. Choose Bypass if you don’t find relevant category for your website. Choosing 

of non-relevant category will break our automatic category suggestion algorithm. 

8. Email Confirmation 

Many directories send email confirmation request to your email used for submission. If 

your email server provides POP3 access, the tool can automate the confirmation process. 
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Choose Confirmation Mail Checker from Tools menu. The Confirmation Email Checker 

Dialog appears.  

 

Figure 8.1: Confirmation Link Checker 

Fill it up with your email account’s details (server, port, username, password, SSL etc) 

and click Check New (or Check All). The tool will retrieve messages from your email 

server, analyzes them and extracts all confirmation links from the text. 

Click Confirm to get all confirmation links visited. 

You can temporarily stop retrieving messages by clicking Stop button. 

9. Check for listing 

The tool checks for listing of your sites in directories and records exact anchor text. 

There are three options: 

• Check for listing in all directories in the list: Choose Submit->Complete Listing 

Check from main menu. 

• Check listing for directories that your site was successfully submitted to: Choose 

Submit->Standard Listing Check from main menu. 

Note: The check process takes several minutes. Please WAIT and DO NOTHING until 

the In Progress counter on the status bar will show 0. 

10. Session Log 

Our tool records submission activity for active session. You can view the log by 

choosing File->View Session Log from main menu.  
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11. Logoff 

You have to log off before leaving the tool. System will back up all information that 

necessary for your next submission. 

12. Additional Functions 

a. Copy category selection: 

By copying category selections for another website, you let the tool know that two 

websites have the same niche and can be submitted to same category. 

Choose My Sites -> Copy Category Selections from main menu. A dialog will appear 

to let you choose the website that its category selection data will be copied over data 

for current active website. 

 

Figure 12.1:  Copy Category Dialog 

In combination with decaptcher service (and under suitable settings for auto 

submission), you can achieve FULLY automated submission process for a new site.  

b. Re-order the directory list randomly 

Directory list can be re-ordered randomly by choosing File > Re-Order Directory List 

randomly. 

c. Arrange site list 

You can change the order of sites how they appear in drop-down site list. Choose My 

Sites -> Arrange Site List form main menu. A dialog will appear. Use Up and Down 

buttons to change the site order, then clicks OK to save. 
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Figure 12.2: Arrange Site List 

d. Edit site profile 

The site profile that has been added can be edited whenever you want to change some 

information. Choose My Sites -> Edit a Site from main menu and a dialog will 

appear. Edit the field that you want and click OK. 

The Categories field contains the category information that you have selected. If you 

made some mistakes when choosing category, you can clear Categories field to blank 

and reset automatic category selection algorithm to achieve more accuracy. 

e. Report Function 

You can get detailed submission report for your individual sites. Choose Submit-

>Submission Report from main menu. The report options dialog appears. Select the 

submissions that you want to include in your report, and then click OK. 

 

Figure 12.4:  Report Options 

The report will be shown in HTML, RFT or CSV format as you choose. You can 

save to file or print directly to printer. 
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Figure 12.5:  Submission Report 

Customized report template is stored in text file report.txt file in application folder. 

By modifying this file, you should get your custom submission report as you want. 

f. Directory List Sort Function 

The directory list can be sorted by several arguments: URL, Page Rank, Submission 

Date, Submission Status and Message/Anchor Text. Simply double-click to the 

header of appropriated column and the tool will sort at once. 

Note: DO NOT perform sorting while submission or listing check process is in 

progress (when In Progress counter located on status bar shows some activity). It 

will cause reporting errors. 

g. Submission Data Backup & Restore 

Some important text files are located in the data folder. You can find the location of 

data folder by open Submit > Options dialog and see Data Folder field. 

• OPTIONS.TXT: Contains optional settings. 

• DATA/*.*: Contains submission data for all sites. 

Backup them regularly!!! 

h. Additional Manual Manipulations: 

Some manual manipulations are useful and can help during submission. 

- Submit to individual directory: Double-click to the directory’s URL in directory 

list. 

- Open Directory in Browser: Double-click to the index of directory in directory 

list. 
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- Check listing in individual directory: Double-click to the directory’s PR in 

directory list. 

- Manual assignment of submission status: Double-click to the directory’s status in 

directory list. A submission status dialog will be shown to allow you to choose 

submission status from the list. 

- Manual assignment of directory’s activity: Double-clicking to the User Mark 

field will switch directory between Active and Inactive State. The Inactive 

directory will be automatically bypassed during mass-submission. 

- View the error message: The error message may be long. For better view, 

double-click to Last Message field and the message will be shown on separated 

window. 
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APPENDIX 

1. FORMAT OF SITE PROFILE DATA FILE  

The site’s profile data file has plain text format as follows: 

# this is comment (Lines that start with ‘#’ character) 

[URL] 
http://www.digixmas.com 
 
[TITLE] 
# List of titles, each on single line 
digiXMAS Directory Submitter 
digiXMAS SEO Tools 
digiXMAS Article Submitter 
 
[DESCRIPTION] 
# List of descriptions, each on single line. Don’t wrap single description on  
# multiple lines. The number of titles and descriptions don’t need to be  
# same, but n of titles must be >= n of descriptions. Principally, title and  
# description come on pair how they appear in the data file: first title with 
# first description, 2nd title with 2nd description etc. 
 
digiXMAS Directory Submitter is fastest bla bla .. 
digiXMAS SEO Tools are fastest bla bla .. 
 
[NAME] 
Your name 
 
[EMAIL] 
Your@email.com 
 
 [PASSWORD] 
12345 
 
[CATEGORY] 
# Categories on single line 
[Top]> Internet > SEO==1#[Top]> Internet > Webmaster==1# 
 
[CATEGORY_KEYWORDS] 
# Category keywords, simple logic operators +- can be used. 
SEO, Search Engine Optimization, Building +Link -Construction 
  
[END] 

 

2. HARDWARE AND SOFTWARE REQUIREMENT 

DigiXMAS Directory Submitter .NET requires good PC with Windows XP, Windows Vista or 

Windows 7 with Microsoft .NET Framework 4.0. 

 

 

 


